Sage++ (Higmmer's Edition) 1.3.11.2 リリース

■ 自作ソフト Posted by ひぐま (Higmmer) on 2007-10-07 at 23:36:35

◆共有テーマ: Firefox [コンピュータ]

本日、Sage++ (Higmmer's Edition) 1.3.11.2をリリースしました。今回の更新内容は以下の通り。

【Sage++ (Higmmer's Edition) 1.3.11.2】 2007/10/07

  • XMLパースエラー発生時、可能なら修復を試みるようにした
    現状、修復されるのは以下のエラーのみ
    • 実体参照化されていない"&"
    • 未定義の実体参照

XMLパースエラーはリンクURLなどに含まれる"&"が正しく"&"のように実体参照化されていない場合に発生することが多いため、上記の対策によってこれまで読めなかったフィードでも読めるようになる可能性があります。お試しあれ。


P.S.
Gran ParadisoのAlpha 8がリリースされたりしてそろそろFirefox 3の正式リリースが近づいてきてるわけだけど、Fx3.0ではブックマーク周りがPlacesに置き換わるためブックマークを利用するSage/Sage++は残念ながら動作しなくなってしまう。これに対応するには大幅なコード修正が必要になると思われ、どうするか現在悩み中。しかもセキュリティ強化の一環でhttps経由の自動更新に対応しないアドオンは全て無効化されるとか(泣)。これにより当ひまグでの配布継続もほぼ絶望的。かと言って元々他人が作ったソフトを自分のものだと言ってMozilla Add-onsに登録申請するだけの図々しさは自分にはない(し、たぶん蹴られるだろう)。既に本家による対応にも期待はできず他に代替となるフィードリーダーも幾つか出てきている現状、敢えてSageにこだわり続ける理由が見出せない限り開発モチベーションが途切れそう。よほど多くの需要/要望が殺到でもすればまた話は別だけど……。

トラックバック

この記事について書く(FC2ブログユーザー)
※言及リンクの無いトラックバックは無効です

PageTop▲

コメント

Posted by YSAIX (ID:dW2OHdfI) [URL]  on 2007-10-08 at 11:15:16 [編集]
Firefox3では大幅な変更があることは知っていましたが、
これでは結構な数のアドオンが動かなくなりそうですね…。
まあ2.0に変わるときもそうでしたが…。
出来ればsage++の対応を望んでいますが、そうもいかないのでしょうね。
でもhttps経由の自動更新しか認めないのはやりすぎな気もしますが…。
■ 安全な方法での自動更新について
Posted by TN (ID:FrUoCQUQ) [URL]  on 2007-10-08 at 18:20:29 [編集]
自分ではまだ試していませんが、httpsでの更新じゃなくても手はあるようですよ。
http://piro.sakura.ne.jp/latest/blosxom/mozilla/xul/2007-09-21_mccoy.htm
ご参考まで。
■ なるほど
Posted by ひぐま (ID:373tx3F.) [URL]  on 2007-10-09 at 00:36:14 [編集]
その方法なら配布に関してはなんとかなりそうですね。
情報ありがとうございます。

PageTop▲

コメントの投稿

 
 
 
 
 
 (後で編集・削除したいなら必須)
 
  

PageTop▲